Internet Explorer Order Page Error
Incident Report for RevolutionParts, Inc
Resolved
Our development team has fixed the issue affecting the order page on Internet Explorer, and all systems are currently operational. We consider this issue to be resolved at this time.
Posted 4 months ago. Jun 10, 2019 - 09:46 MST
Monitoring
Our development team has pushed a fix for the issue affecting the order page on Internet Explorer, and all systems appear to be working normally. We will continue monitoring the system to ensure correct performance.
Posted 4 months ago. Jun 10, 2019 - 09:13 MST
Identified
Our development team has identified the issue, and is currently working on a resolution. We will provide further updates as soon as they are available.
Posted 4 months ago. Jun 10, 2019 - 09:02 MST
Investigating
We are currently experiencing an issue that is affecting the ability to open/view orders when using Internet Explorer. Our development team is investigating to find the cause of the issue, and we will provide updates as they become available.

Until the issue is resolved, orders appear to be working correctly in Google Chrome and Mozilla Firefox. We recommend using either of these browsers until functionality is restored to Internet Explorer.
Posted 4 months ago. Jun 10, 2019 - 08:15 MST
This incident affected: RevolutionParts Platform.