Customer Information is missing on Amazon Orders
Incident Report for RevolutionParts, Inc
Resolved
We continue to have an issue with our Amazon integration causing us to not receive buyer billing and shipping information for orders received through the Amazon selling channel. We are actively engaged with Amazon and have requested escalation of the issue but at this time do not have estimated time of resolution. In the meantime, please continue to process orders received directly through your Amazon account. Our Development team is actively working on a product update to make it easier to go directly to your Amazon order from the RevolutionParts control panel, and we expect that to be out today.

Due to this issue being limited to orders received through the Amazon selling channel, we'll be moving our communication regarding updates to emailing those customers impacted directly. If you have any questions, please contact our Customer Support team directly at 480-779-7278 or support@revolutionparts.com. We appreciate your patience.
Posted 10 days ago. Aug 09, 2019 - 11:46 MST
Identified
The issue has been identified and a fix is being implemented.
Posted 16 days ago. Aug 02, 2019 - 19:56 MST
Investigating
We are currently experiencing an integration issue that is causing our system to not receive end-user billing and shipping information on Amazon orders. Our development team has identified the cause of the issue, but we do expect this issue to persist through the weekend as the solution will require intervention from Amazon. While we work on this solution, we recommend processing affected orders directly through Amazon. We appreciate your patience, and will provide updates as they are available.
Posted 16 days ago. Aug 02, 2019 - 19:55 MST
This incident affected: RevolutionParts Platform and External Systems.