USPS / Stamps.com Outage
Incident Report for RevolutionParts, Inc
Resolved
Stamps.com has fixed the issue affecting label printing, and all systems are currently operational. We consider this issue to be resolved at this time.
Posted Oct 19, 2020 - 17:04 MST
Monitoring
Stamps.com appears to have fixed the issue affecting USPS label creation. We will continue monitoring the system to ensure correct performance.
Posted Oct 19, 2020 - 15:37 MST
Investigating
Stamps.com is currently experiencing an outage that is affecting the ability to generate/print USPS shipping labels. We will provide updates as they become available.
Posted Oct 19, 2020 - 11:01 MST
This incident affected: External Systems.