A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2026 - 09:14 MST
Investigating
Support has received increased reports that users are unable to create USPS labels through RP Shipping. While we investigate these reports, UPS options appear to be working as normal.
Posted Sep 22, 2026 - 07:38 MST
This incident affected: RevolutionParts Platform and External Systems.