FedEx Services Interrupted

Incident Report for RevolutionParts, Inc

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 14:33 MST

Monitoring

FedEx API error rates have returned to normal. FedEx is reporting the status as resolved. Will continue to monitor.
Posted Jun 26, 2026 - 13:12 MST

Identified

FedEx integration services through the platform are currently interrupted due to external systems.
Posted Jun 26, 2026 - 10:25 MST
This incident affected: External Systems.