Bulk Reports Stuck Pending

Incident Report for RevolutionParts, Inc

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 07:25 MST

Monitoring

A fix has been implemented; pending and new jobs will resolve slowly as the queue catches back up.
Posted Jun 23, 2026 - 15:01 MST

Identified

Our engineers are working on a fix for an issue preventing bulk report jobs from completing.
Posted Jun 23, 2026 - 11:48 MST
This incident affected: RevolutionParts Platform.