New orders might not appear in the RevolutionParts dashboard

Incident Report for RevolutionParts, Inc

Resolved

This incident has been resolved. However, as our systems continue to recover there may be a slight delay before all affected orders are once again visible and accessible within your RevolutionParts account.
Posted Oct 15, 2024 - 15:08 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2024 - 14:08 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 15, 2024 - 13:15 MST

Investigating

We are currently investigating an issue where a new order email notification is received but it is not possible to locate the order in RP Admin.
Posted Oct 15, 2024 - 11:58 MST
This incident affected: RevolutionParts Platform.