Intermittent Payment and Checkout Issues

Incident Report for RevolutionParts, Inc

Resolved

This incident has been resolved.
Posted May 04, 2023 - 11:35 MST

Update

The ability to check out on affected web stores and to capture payments on newly received orders is now restored. Thank you for your patience.
Posted May 04, 2023 - 11:35 MST

Monitoring

We are currently monitoring an issue affecting the checkout page on a limited number of sites. This issue could also affect the ability to capture certain payments on newly received orders.
Posted May 04, 2023 - 10:49 MST
This incident affected: RevolutionParts Platform.