Intermittent Platform Outage

Incident Report for RevolutionParts, Inc

Resolved

This incident has been resolved.
Posted May 07, 2026 - 18:23 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 07, 2026 - 18:06 MST

Investigating

We have identified an issue where some webstores are displaying "502 Bad Gateway" errors, making affected sites inaccessible. This has been traced back to a service disruption with our infrastructure provider, Amazon Web Services (AWS).

While the root cause lies externally, our engineering team is actively monitoring the situation and working closely with AWS support to ensure service is restored as quickly as possible.
Posted May 07, 2026 - 17:58 MST
This incident affected: RevolutionParts Platform.